0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Заметки о кошководстве: )

Маленькое дополнение про Native VLAN.

Так как кадры Native VLAN обязаны проходить по транк-линкам без тегов, появление в транк-линке кадра с тегом номер которого совпадает с номером Native VLAN является не допустимым, и коммутатор получив такой кадр его уничтожает.
Скачать: pkt-файл

PS в pkt-файле есть небольшое изменение. Порты коммутаторов fa 0/2 переведены в режим trunk. Результат точно такой же, кадры идут без тега и дублируются на порты распределенные в первый влан (т.к. он же native) и наоборот.
PPS если задать на коммутаторах разные Native vlan, то можно получить ситуацию с отбрасыванием кадров при совпадении тега с номером native vlan.

18 комментариев:

Тогда не должен пройти пинг от pc5 к pc6(транковый vlan совпадет с тегом vlan1), и судя по всему 1 коммутатор должен такой пакет отбросить.Я правильно понимаю?

Пройдёт элементарно этот пинг.
А что значит транковый vlan? Транк тегирует кадр, указывая там принадлежность кадра к определённому vlan, если это кадр native vlan, то транк с ним ничего не делает.

пинг будет проходить потому, что в данной лабе native vlan на коммутаторах совпадает.

Статья в тему:  Трудные пароли для вк. Какой пароль можно придумать для ВК

тоесть Native vlan совпадает с vlan1(судя по написаному вами выше «Так как кадры Native VLAN обязаны проходить по транк-линкам без тегов, появление в транк-линке кадра с тегом номер которого совпадает с номером Native VLAN является не допустимым, и коммутатор получив такой кадр его уничтожает.»)
Это уточнение к первому вопросу,хочу разобраться.Спасибо.

native vlan совпадает с vlan1 по умолчанию, но вы при желании можете это изменить.
Да, он действительно его уничтожит, потому как это будет означать, что на коммутаторах не совпадает native vlan, эта проблема довольно просто исправляется, на одном из коммутаторов просто меняете native vlan на такой же самый (как и на других устройствах домена).

Если в транк с native vlan 10 попадет тегированный траффик(vlan 10) транк просто снимет этот тэг.

да на входе в транк свич снимет тег с такого кадра.
но если каким то чудом в самом транке появится тегированный кадр и прийдет на порт коммутатора он должен его отбросить.

Я бы немного уточнил последнее предложение, добавив некоторые слова для более лучшего восприятия. Вот как это бы выглядело: «Так как кадры ПРИНАДЛЕЖАЩИЕ Native VLAN обязаны проходить по транк-линкам без тегов, появление в транк-линке кадра с тегом номер которого совпадает с номером Native VLAN КОММУТАТОРА, КОТОРЫЙ ПОЛУЧАЕТ ЭТОТ КАДР, является не допустимым, и коммутатор, получив такой кадр, его уничтожает.»

Статья в тему:  Файлы pptx: чем открыть. Чем открыть pptx

насчет того, отбрасывается ли такой кадр это еще под вопросом. все никак не проверю на оборудовании

Смоделировал схему в PT по которой коммутатор получив из транка номер Native VLAN’а должен удалять такой VLAN. Ну. Ни хрена. Не удаляет. Коммутатору не фильтрует номера VLAN’ов в транке, если они совпадают с Native VLAN’ом. Он их пропускает через себя без ограничений.
Если интересно, попробуйте сами:
ROUTER1:
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0

ROUTER2:
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.0

SW1, SW2:
interface FastEthernet0/1
switchport trunk native vlan 10
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 10
switchport mode trunk

Схема: ROUTER1 SW1 SW2 ROUTER2

да я в курсе. последнюю неделю как раз этот вопрос разбирал )))
видимо все таки в курсе ошибка или неверная формулировка.

Назначение VLAN

Основной причиной разделения сети на сети VLAN является сокращение перегрузок в большой локальной сети. Чтобы понять эту проблему, нам нужно вкратце остановиться на том, как LAN развиваются на протяжении многих лет. Первоначально локальные сети были очень плоскими — все рабочие станции были подключены к одному кусочку коаксиального кабеля или к наборам цепных хабов. В плоской локальной сети каждый пакет, который любое устройство помещает в провод, отправляется на все другие устройства в локальной сети. По мере роста числа рабочих станций в типичной локальной сети они начали безнадежно перегружаться; было слишком много коллизий, потому что большую часть времени, когда рабочая станция пыталась отправить пакет, выяснилось, что провод уже занят пакетом, отправленным каким-либо другим устройством.

Статья в тему:  Как поменять ос на андроиде. Система: обновление или прошивка

Чтобы справиться с этой проблемой разработали три основных решения для избежания перегрузки:

Использование маршрутизаторовдля сегментирования локальных сетей

Использование коммутаторов для сегментов LAN

Использование VLAN для сегментирования локальных сетей

Использование VLAN для сегментирования локальных сетей

По мере увеличения LAN скорость передачи данных стала быстрее, и пользователи стали более гибкими, маршрутизаторы в сети стали узким местом. Это потому что:

  • маршрутизаторы обычно передают данные в программном обеспечении, и поэтому не так быстро, как коммутаторы
  • разделение LAN с использованием маршрутизаторов означало, что локальная сеть обычно соответствует определенному физическому местоположению. Это стало ограничивающим фактором, когда многие пользователи имели ноутбуки и хотели иметь возможность перемещаться между зданиями, но все же иметь одну и ту же сетевую среду, где бы они ни были подключены.

Таким образом, поставщики коммутаторов начали внедрять методы определения «виртуальных локальных сетей» -сетей портов коммутатора, обычно распределенных между несколькими коммутаторами, которые каким-то образом взаимодействовали, как если бы они находились в одной изолированной локальной сети. Таким образом, рабочие станции могут быть разделены на отдельные локальные сети без физического разделения маршрутизаторами.

Примерно в то же время хабы стали менее популярными и в значительной степени были заменены коммутаторами L2. Это сделало всю концепцию области столкновения несколько исторической. В современных сетях «домен столкновения» в основном состоит из одного устройства, подключенного к порту коммутатора L2, или, возможно, ПК с чем-то вроде подключенного к нему IP-телефона.

Статья в тему:  Мухосранск реальный город. Мухосранск

Итак, макет LAN стал больше похож на:

Таким образом, вместо локальных сетей, соответствующих физическим областям, разделенным между собой маршрутизаторами, существуют виртуальные локальные сети, распределенные по сети. Например, все устройства в различных областях, обозначенные как «VLAN A», все принадлежат одной виртуальной локальной сети — один широковещательный домен.

Virtual LAN (VLAN)

Что же такое VLAN?

Давайте разберем пример на рисунке 4.1. В организации есть несколько отделов, все сотрудники подключены к одному коммутатору – это значит, что каждый компьютер в сети видит все остальные, для бухгалтерии важна безопасность и компьютеры этого отдела надо оградить от всех остальных (эта информация исключительно для примера). Как же тогда построить сеть? Как вариант можно поставить второй коммутатор (рисунок 4.2), но покупать новый коммутатор ради трех компьютеров не очень разумно. На помощь приходят VLAN-ы позволяющие логически разделять коммутатор так, что компьютеры в одном VLAN не могут общаться с компьютерами в другом VLAN, хотя будут подключены к одному коммутатору, рисунок 4.3.

Рисунок 4.2 Пример разделения департаментов

Рисунок 4.3 Разделение по VLAN

Разграничение по VLAN возможно за счет указания принадлежности порта к определенному VLAN. В cisco коммутаторах все порты по умолчанию принадлежат VLAN 1.

Что же такое Trunk?

В некоторых источниках Trunk (транк) – это провод соединяющий коммутаторы, но мы будем рассматривать это как канал связи между коммутаторами, который пропускает фреймы, принадлежащие разным VLAN. Чтобы лучше понять, предлагаю разобрать пример на рисунке 4.4.

Статья в тему:  Основные шрифты windows. Безопасные шрифты

Рисунок 4.4 Trunk

В нашем примере имеется только два VLAN. Порты коммутаторов, к которым подключены ПК3, ПК4 и ПК5, принадлежат Vlan10. Соответственно остальные компьютеры подключены к портам, принадлежащим vlan13. Как же второй коммутатор понимает из какого VLAN к нему пришел фрейм? За счет тегированных фреймов. Давайте пошагово разберем пересылку данных от ПК4 к ПК5:

  1. ПК4 формирует и отправляет фрейм адресованный ПК5, оба компьютера не знают о существовании VLAN.
  2. Коммутатор (sw_1) принимает фрейм и сразу отмечает, что пришедший фрейм принадлежит Vlan10 и надо отправить его в сторону второго коммутатора (sw_2). Между коммутаторами настроен trunk, и по нему проходят тегированные фреймы.Таким образом коммутатор (sw_1) изменяет фрейм, добавляя к нему тег (рисунок 4.5), в котором сообщается к какому vlan относится этот фрейм, и отправляет его.
    Рисунок 4.5 Тегированный фрейм
  3. Второй коммутатор (sw_2) принимает фрейм и видит, что он принадлежит vlan10, смотрит на каком порту находится MAC-адрес получателя в vlan10. Коммутатор принимает решение отправить фрейм компьютеру ПК5, предварительно сняв тег (метку).
  4. ПК5 получает фрейм и даже не догадывается о существовании VLAN, транков и прочих сложностей, для него все это прозрачно.
  • vlan 1 – административный vlan, создан по умолчанию, по умолчанию каждый порт принадлежит этому vlan;
  • vlan-ны с 2 по 1001 – нормальные vlan-ы. Чаще всего, из этого диапазона vlan-ов можно создавать на коммутаторе новые vlan (включая первый vlan);
  • c 1002 по 1005 зарезервированы под будущие цели (лучше помнить, что они просто зарезервированы и не могут быть использованы при добавлении новых vlan);
  • c 1006 по 4094 “расширенные” vlan. Из этого диапазона можно создавать новые vlan, если позволяет прошивка и соблюдены некоторые нюансы.
Статья в тему:  Разъемы на карте gtx 1050 ti. Видеокарты


Для связи устройств из одного VLAN с устройствами в другом VLAN надо использовать роутер.

Общая информация

Packet Tracer version: 6.2.0

Рабочий файл: скачать

Тип: Теория и практика

Версия файла: 2.0

Уже получили: 155 пользователей

Справочная информация

Номера VLAN (VLAN ID)

Номера VLAN (VLAN ID) могут быть в диапазоне от 1 до 4094:

  • 1 — 1005 базовый диапазон (normal-range)
  • 1002 — 1005 зарезервированы для Token Ring и FDDI VLAN
  • 1006 — 4094 расширенный диапазон (extended-range)

Параметры VLAN

При создании или изменении VLAN можно задать следующие параметры:

  • VLAN ID — Номер VLAN
  • VLAN name (name) — Имя VLAN
  • VLAN type (media) — Тип VLAN (Ethernet, Fiber Distributed Data Interface [FDDI], FDDI network entity title [NET], TrBRF, или TrCRF, Token Ring, Token Ring-Net)
  • VLAN state (state) — Состояние VLAN (active или suspended)
  • VLAN MTU (mtu) — Максимальный размер блока данных, который может быть передан на канальном уровне
  • SAID (said) — Security Association Identifier — идентификатор ассоциации безопасности (стандарт IEEE 802.10)
  • Remote SPAN (remote-span) — Создание VLAN для удаленного мониторинга трафика (В дальнейшем в такой VLAN можно зеркалировать трафик с какого-нибудь порта, и передать его через транк на другой коммутатор, в котором из этого VLAN трафик отправить на нужный порт с подключенным снифером)
  • Bridge identification number для TrBRF VLAN (bridge) — Идентификатор номера моста для функции TrBRF (Token Ring Bridge Relay Function). Цель функции — создание моста из колец.
  • Ring number для FDDI и TrCRF VLAN (ring) — Номер кольца для типов VLAN FDDI и TrCRF (Token Ring concentrator relay functions). TrCRF называют кольца, которые включены в мост.
  • Parent VLAN number для TrCRF VLAN (parent) — Номер родительского VLAN для типа VLAN FDDI или Token Ring
  • Spanning Tree Protocol (STP) type для TrCRF VLAN (stp type) — Тип протокола связующего дерева (STP) для VLAN типа TrCRF
  • Translational VLAN number 1 (tb-vlan1) — Номер VLAN для первичного преобразования одного типа VLAN в другой
  • Translational VLAN number 2 (tb-vlan2) — Номер VLAN для вторичного преобразования одного типа VLAN в другой
Статья в тему:  Почта net ua войти. Ukr net почта вход

Значения по умолчанию

VLAN ID1
VLAN nameVLANxxxx, где xxxx четыре цифры номера VLAN (Например: VLAN0003, VLAN0200 и т.д.)
SAID100000 плюс VLAN ID (Например: 100001 для VLAN 1, 100200 для VLAN 200 и т.д.)
VLAN MTU1500
Translational VLAN number 1
Translational VLAN number 2
VLAN stateactive
Remote SPANdisabled

Доставка по Москве, Санкт-Петербургу, в регионы России, в Казахстан, Беларусь

Оперативно подберем для Вас оборудование и аналоги

Ссылка на основную публикацию
Статьи c упоминанием слов:

Adblock
detector